IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> Проблема с установкой программ
Поделиться
интересующийся
сообщение 1.7.2018, 22:22
Сообщение #1


Специалист
****

Группа: Пользователь
Сообщений: 215
Регистрация: 14.12.2012
Вставить ник
Цитата
Пользователь №: 2346
Страна: Украина
Город: Полтава
Пол: Муж.



Репутация: 1


Выделено из темы "Переход на восьмой Альт"

Цитата(robinzoid @ 23.4.2017, 9:31) *
Выделено из темы "Проблемы с седьмым Альтом"

Опять проблема с седьмым Альтом. Ну то есть я понимаю что все цивилизованные люди уже давно на Альте восьмом, но вот не нравится мне КДЕ 5 чисто визуально. Пока остаюсь на седьмом.
А вопрос такой: у меня уже давно с p7 никаких обновлений не приходит. Видимо на него уже рукой махнули и не поддерживают. А если я репозиторием p8 назначу, у меня ничего не поломается?? Смысл в этом есть хоть какой?
Сдуру-то ведь много чего поломать можно.

видимо и на восьмой махнули.я сейчас пользую стартеркит с xfce. хотел свои привычные программы поставить так синаптик не может обеспечиь всеми зависимостями. пишет например : " Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
так жаль, это мой любимый во все времена легенький редактор....и не только от него придется отказаться....
а вот репы п6 до сих пор на удивление хорошо работают и очень даже экзотический софт можно найти


--------------------
Каким бы языком вы ни пользовались, вы никогда не сможете сказать ни чего другого, кроме того, кто вы такой
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 1.7.2018, 23:05
Сообщение #2


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Установил в сборке на p8 abiword - естественно, со всеми зависимостями, включая тот самый abiword-data-3.0.2-alt0.M80P.1. Никаких проблем. Правда, это в 64-битной сборке.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
kostyalamer
сообщение 2.7.2018, 7:22
Сообщение #3


Профессионал
*******

Группа: Модератор раздела
Сообщений: 4399
Регистрация: 17.9.2009
Вставить ник
Цитата
Пользователь №: 1617
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 20


У меня он работает на p8 32-бита без каких либо проблем. А стартер у вас на SysVinit или SystemD ?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Антон Мидюков
сообщение 2.7.2018, 22:08
Сообщение #4


Специалист
****

Группа: Пользователь
Сообщений: 114
Регистрация: 28.6.2015
Вставить ник
Цитата
Из: Прокопьевск
Пользователь №: 2818
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 5


Цитата(интересующийся @ 2.7.2018, 1:22) *
видимо и на восьмой махнули.я сейчас пользую стартеркит с xfce. хотел свои привычные программы поставить так синаптик не может обеспечиь всеми зависимостями. пишет например : " Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
так жаль, это мой любимый во все времена легенький редактор....и не только от него придется отказаться....
а вот репы п6 до сих пор на удивление хорошо работают и очень даже экзотический софт можно найти


Обновляться нужно через dist-upgrade в консоли.
apt-get update && apt-get dist-upgrade
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
интересующийся
сообщение 3.7.2018, 11:38
Сообщение #5


Специалист
****

Группа: Пользователь
Сообщений: 215
Регистрация: 14.12.2012
Вставить ник
Цитата
Пользователь №: 2346
Страна: Украина
Город: Полтава
Пол: Муж.



Репутация: 1


Цитата(IVK @ 1.7.2018, 21:05) *
Установил в сборке на p8 abiword - естественно, со всеми зависимостями, включая тот самый abiword-data-3.0.2-alt0.M80P.1. Никаких проблем. Правда, это в 64-битной сборке.

ну а у меня ничего не получается может потому что 32?
the following packages have unresorvable dependencies. make sure that all required repositories are added and enabled in the preferences
включены
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
что может быть не так?


--------------------
Каким бы языком вы ни пользовались, вы никогда не сможете сказать ни чего другого, кроме того, кто вы такой
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 3.7.2018, 22:31
Сообщение #6


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(интересующийся @ 1.7.2018, 20:22) *
видимо и на восьмой махнули. ... так синаптик не может обеспечиь всеми зависимостями. пишет например :
" Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
что может быть не так?


Подозреваю что "його неможлыво встановыты" потому, что предварительно не обновлена локальная база пакетов:
- Базу менеджер отображает старую, с пакетами которых уже на сервере нет. Они уже обновились. Стало быть и локальную базу нужно обновить перед установкой пакета(ов).

В synaptic должны быть настроены цели для 32 бит:
Код
--------------------------------------------------------------------------------------------------------
|Разрешён|Тип|Поставщик|URI                                                 |Дистрибутив      |Раздел(ы) |
--------------------------------------------------------------------------------------------------------|
|   v     rpm p8        http://ftp.altlinux.org/pub/distributions/ALTLinux/  p8/branch/i586    classic   |
|   v     rpm p8        http://ftp.altlinux.org/pub/distributions/ALTLinux/  p8/branch/noarch  classic   |


Для установки abiword:

Нажать кнопку:
Оновити список пакунків
Ждать завершения операции.

Отметить двойным щелчком abiword

synaptic предложит окно:
Позначити необхідні додаткові зміни?
со списком пакетов включая abiword-data
Надо согласиться нажав кнопку
Позначити

Затем на панели synaptic нажать кнопку
Застосувати

В окне
Прийняти наступні зміні?
нажать кнопку
Застосувати

В окне
Завантаження файлів пакунків
начнётся процесс скачивания пакетов.

В конце появится окно
Прийняття змін
Ждите

По завершении всех операций появится окно
Вивід менеджера пакунків
с сообщением
Done (Готово)

Закройте окно нажав кнопку
Закрити
Все. smile.gif

Сообщение отредактировал speccyfighter - 4.7.2018, 5:12
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 4.7.2018, 19:46
Сообщение #7


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(интересующийся @ 3.7.2018, 9:38) *
ну а у меня ничего не получается может потому что 32?
the following packages have unresorvable dependencies. make sure that all required repositories are added and enabled in the preferences
включены
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
что может быть не так?


Проверил установку abiword через synaptic на установленной alt-p8-sysv-xfce-20180312-i586.iso
abiword устанавлиается и работает.

Уберите цели по протоколу ftp и оставьте только по http. Обновите локальную базу.
Что мне припоминается:
Редко, но пользуюсь местным сервером по ftp у которого вроде бы ограничение в полусотню коннектов. При превышении будет отказ в доступе.

Если есть apt-indicator, уберите его, - он чаще мешает чем помогает.

Сообщение отредактировал speccyfighter - 4.7.2018, 19:59
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
интересующийся
сообщение 4.7.2018, 23:55
Сообщение #8


Специалист
****

Группа: Пользователь
Сообщений: 215
Регистрация: 14.12.2012
Вставить ник
Цитата
Пользователь №: 2346
Страна: Украина
Город: Полтава
Пол: Муж.



Репутация: 1


Цитата(Антон Мидюков @ 2.7.2018, 20:08) *
Обновляться нужно через dist-upgrade в консоли.
apt-get update && apt-get dist-upgrade

гениально! я знал! знал, но... забыл просто. давно не устанавливал систему.
ругается синаптик на фтп. я включил зеркала. пока работает. Эбиворд уже себе установил. радуюсь


--------------------
Каким бы языком вы ни пользовались, вы никогда не сможете сказать ни чего другого, кроме того, кто вы такой
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
интересующийся
сообщение 5.7.2018, 0:02
Сообщение #9


Специалист
****

Группа: Пользователь
Сообщений: 215
Регистрация: 14.12.2012
Вставить ник
Цитата
Пользователь №: 2346
Страна: Украина
Город: Полтава
Пол: Муж.



Репутация: 1


alt-p8-xfce-20180612-i586 у меня что лежало на Альт линукс.орг-то и взял. лишь бына флеху гектарную влезло.
правда сначала МАТЕ или (МЭЙТ?) попробовал но отказаться пришлось хоть и понравился.


--------------------
Каким бы языком вы ни пользовались, вы никогда не сможете сказать ни чего другого, кроме того, кто вы такой
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 24.1.2019, 19:06
Сообщение #10


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Переместил последнее сообщение отсюда в тему "Активатор windows". Тут у нас раздел про Линукс smile.gif Вообще, это не самый подходящий форум для решения виндовых проблем wink.gif


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 12.7.2020, 11:05
Сообщение #11


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Отделил отсюда тему " Droidcam".


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 13.7.2020, 11:34
Сообщение #12


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Попытался сейчас zoom в Альт установить, увы...

# apt-get install zoom_i686.rpm
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано zoom для 'zoom_i686.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
zoom: Требует: ibus-m17n но пакет не может быть установлен
Требует: mesa-dri-drivers(x86-32) но пакет не может быть установлен
E: Извините, `битые' пакеты


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 13.7.2020, 18:22
Сообщение #13


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(robinzoid @ 13.7.2020, 9:34) *
Попытался сейчас zoom в Альт установить, увы...
...
Следующие пакеты имеют неудовлетворенные зависимости:
zoom: Требует: ibus-m17n но пакет не может быть установлен
Требует: mesa-dri-drivers(x86-32) но пакет не может быть установлен
E: Извините, `битые' пакеты

Код
$ apt-cache search mesa-dri-drivers # p9 x86_64
mesa-dri-drivers - Mesa-based DRI drivers

Код
$ apt-cache search ibus-m17n # p9 x86_64
ibus-m17n - The M17N engine for IBus platform

Есть и в i586.
Но с p8 не судьба...
p8 уже не поддерживается. Забудьте про него.

И:
Сначала нужно обновлять базу. И делать это нужно минимум раз в сутки. И лишь потом искать или устанавливать пакеты.


Сообщение отредактировал speccyfighter - 13.7.2020, 18:35
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 13.7.2020, 19:08
Сообщение #14


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


В альтах на p9, лучше использовать zoom для CentOS (симуляция установки zoom, - опция -s - симуляция, имитация), установка пакета x86_64 пройдёт удачно:
Код
# apt-get install ./zoom/zoom_x86_64.rpm -s # p9 x86_64 zoom для CentOS
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано zoom для './zoom/zoom_x86_64.rpm'
Следующие дополнительные пакеты будут установлены:
  ibus ibus-dicts ibus-m17n libibus libibus-gir libm17n libm17n-gui m17n-utils mesa-dri-drivers python3-module-ibus-overrides zoom
Следующие НОВЫЕ пакеты будут установлены:
  ibus ibus-dicts ibus-m17n libibus libibus-gir libm17n libm17n-gui m17n-utils mesa-dri-drivers python3-module-ibus-overrides zoom
0 будет обновлено, 11 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
Inst ibus-dicts (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Inst libibus (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Inst libibus-gir (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Inst ibus (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Inst python3-module-ibus-overrides (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Inst libm17n (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Inst libm17n-gui (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Inst m17n-utils (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Inst ibus-m17n (1.4.2-alt2:p9+248344.100.1.1<>1584980017 p9:1594411846/ALT Linux p9)
Inst mesa-dri-drivers (4:20.1.1-alt1:p9+253152.100.3.1<>1592218706 p9:1594411846/ALT Linux p9)
Inst zoom (5.1.422789.0705-1<>1594007434 localhost)
Conf ibus-dicts (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Conf libibus (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Conf libibus-gir (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Conf ibus (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Conf python3-module-ibus-overrides (1.5.22-alt2:p9+250350.100.1.1<>1587462865 p9:1594411846/ALT Linux p9)
Conf libm17n (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Conf libm17n-gui (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Conf m17n-utils (1.8.0-alt1<>1533249631 p9:1594411846/ALT Linux p9)
Conf ibus-m17n (1.4.2-alt2:p9+248344.100.1.1<>1584980017 p9:1594411846/ALT Linux p9)
Conf mesa-dri-drivers (4:20.1.1-alt1:p9+253152.100.3.1<>1592218706 p9:1594411846/ALT Linux p9)
Conf zoom (5.1.422789.0705-1<>1594007434 localhost)

но не для openSUSE
Код
# apt-get install ./zoom/zoom_openSUSE_x86_64.rpm -s # p9 x86_64 zoom для openSUSE
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано zoom для './zoom/zoom_openSUSE_x86_64.rpm'
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  zoom: Требует: libgobject-2_0-0 но пакет не может быть установлен
        Требует: libXi6 но пакет не может быть установлен
        Требует: libSM6 но пакет не может быть установлен
        Требует: libdbus-1-3 но пакет не может быть установлен
        Требует: libasound2 но пакет не может быть установлен
E: Извините, `битые' пакеты

Или использовать тарбол zoom, с проверкой elf-файла через ldd-requires, для проверки удовлетворения всех зависимостей.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 14.7.2020, 16:29
Сообщение #15


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Спасибо. Они в общем и предупреждают что у них зум только для 64-битной версии.
Что в общем, нехорошо. Не так давно, когда школьники сели на дистанционку, им уроки стали давать в зуме. И если у кого была 32-битная версия Альта, то у них стали возникать очень серьёзные заморочки. Кубунта 14.04 (32 бита) зум установила в момент, а Альт чего-то кочевряжится.
Впрочем моих заморочек это не касается. У меня сейчас

[altlinux<>localhost ~]$ cd 64
[altlinux<>localhost 64]$ ./install
— INSTALL: Webcam parameters: '640' and '480'
— INSTALL: Home directory: /home/altlinux/.droidcam
— INSTALL: Building v4l2loopback-dc.ko
make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: *** /lib/modules/5.4.41-std-def-alt1/build: Нет такого файла или каталога. Останов.
make: *** [Makefile:4: all] Ошибка 2
— INSTALL: v4l2loopback-dc.ko not built.. Failure
Но это наверно из другой темы.


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 15.7.2020, 0:56
Сообщение #16


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(robinzoid @ 14.7.2020, 14:29) *
[altlinux<>localhost ~]$ cd 64
[altlinux<>localhost 64]$ ./install
...
Но это наверно из другой темы.

Из этой:
http://www.dev47apps.com/droidcam/linux/
https://www.linuxcenter.ru/lib/books/kostro.../gl_04_05.phtml

Цитата(robinzoid @ 14.7.2020, 14:29) *
...
make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: *** /lib/modules/5.4.41-std-def-alt1/build: ...
...

Версии хидеров и версия ядра должны совпадать.

Цитата(robinzoid @ 14.7.2020, 14:29) *
...
make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: *** /lib/modules/5.4.41-std-def-alt1/build: Нет такого файла или каталога. Останов.
...

Каталог build /lib/modules/$(uname -r)/build (точнее симлинк) создаётся на установке хидеров и при удалении хидеров, удаляется.
Например:
Хидеры установлены, build есть:
Код
# ll /lib/modules/5.4.51-std-def-alt1/| grep build | wc -l
1

Код
# ll /lib/modules/5.4.51-std-def-alt1/build
lrwxrwxrwx 1 root root 34 июл 14 23:22 /lib/modules/5.4.51-std-def-alt1/build -> /usr/src/linux-5.4.51-std-def-alt1/

Удаляем хидеры:
Код
# apt-get install kernel-headers-std-def- kernel-headers-modules-std-def-

build нет:
Код
# ll /lib/modules/5.4.51-std-def-alt1/| grep build | wc -l
0

Код
# ll /lib/modules/5.4.51-std-def-alt1/build
ls: невозможно получить доступ к '/lib/modules/5.4.51-std-def-alt1/build': Нет такого файла или каталога

Устанавливаем хидеры:
Код
# apt-get install kernel-headers-std-def kernel-headers-modules-std-def

build есть:
Код
# ll /lib/modules/5.4.51-std-def-alt1/| grep build | wc -l
1

Код
# ll /lib/modules/5.4.51-std-def-alt1/build
lrwxrwxrwx 1 root root 34 июл 14 23:26 /lib/modules/5.4.51-std-def-alt1/build -> /usr/src/linux-5.4.51-std-def-alt1/

Если в команде apt-get install в конце имени пакета стоит минус, то несмотря на команду install, пакет не устанавливается, а удаляется.

Текущие хидеры и ядро в p9/branch, 5.4.51-std-def-alt1, - не 5.4.41-std-def-alt1!
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 15.7.2020, 12:10
Сообщение #17


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Всё на что я способен это глянуть в инете что такое "хидер". А там

"Термин "Хидер" происходит от слова "header" и пришло к нам из лексикона американо-канадских строителей каркасных домов и официально используется в "КОД". Ни один дом, построенный по канадской технологии или по СП 31-105-2002 не обходится без "хидеров".

Ну и что я пойму??:


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 15.7.2020, 13:03
Сообщение #18


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(robinzoid @ 15.7.2020, 10:10) *
Всё на что я способен это глянуть в инете что такое "хидер". А там

"Термин "Хидер" происходит от слова "header" и пришло к нам из лексикона американо-канадских строителей каркасных домов и официально используется в "КОД". Ни один дом, построенный по канадской технологии или по СП 31-105-2002 не обходится без "хидеров".

Ну и что я пойму??:

Понять можно было, внимательно просмотрев мой вчерашний ответ
Цитата(speccyfighter @ 14.7.2020, 14:43) *
Код
# apt-get update

Код
# uname -r
5.4.51-std-def-alt1

Код
# apt-cache show kernel-headers-modules-std-def | grep ^Vers
Version: 1:5.4.51-alt1:p9+254734.100.2.1<>1594405161

Код
# apt-cache show kernel-headers-std-def | grep ^Vers
Version: 1:5.4.51-alt1:p9+254734.100.2.1<>1594405161

в котором показано, что версии хидеров имеющихся в репозитории, соответствуют версии ядра используемого системой

и их можно устанавливать:
Цитата(speccyfighter @ 14.7.2020, 14:43) *
Код
# apt-get install kernel-headers-std-def kernel-headers-modules-std-def

Потому что каталог (симлинк) build, при установке хидеров ядра, создаётся в каталоге используемого системой ядра версии, которой должны соответствовать устанавливаемые хидеры.
См. наглядный пример в Сообщении #16 этой темы.

Сообщение отредактировал speccyfighter - 15.7.2020, 13:06
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 28.7.2020, 11:21
Сообщение #19


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


А в принципе можно в 9-й Альт вместо Гимпа 2.10 установить Гимп 2.8 из предыдущего бранча. Пытался нахрапом, но установщик rpmки чего-то завис...
Или надо сам бранч подключать? Или чего-то ещё надо??

Прикрепленный файл  Screenshot_20200728_101555.jpg ( 309.29 килобайт ) Кол-во скачиваний: 2


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 28.7.2020, 16:43
Сообщение #20


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


По-моему, не надо таких экспериментов. Бранчи мешать - крайне сомнительное занятие wink.gif А что, новый Гимп совсем никуда не годится? mellow.gif Может, просто непривычка?


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 29.7.2020, 14:36
Сообщение #21


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


У нас тут про эту "Альфу в логотип" есть даже отдельная тема, так что туда и перекинул отсюда 5 постов.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
speccyfighter
сообщение 29.7.2020, 20:48
Сообщение #22


Крупный специалист
*****

Группа: Пользователь
Сообщений: 442
Регистрация: 1.5.2013
Вставить ник
Цитата
Пользователь №: 2379
Страна: Беларусь
Город: Не указан
Пол: Муж.



Репутация: 1


Цитата(robinzoid @ 28.7.2020, 9:21) *
А в принципе можно в 9-й Альт вместо Гимпа 2.10 установить Гимп 2.8 из предыдущего бранча.

Можно.
С таким количеством зависимостей по версия-релиз, система развалится гарантированно:
Код
$ apt-cache depends gimp
gimp-2.10.18-alt2:p9+251602.500.10.1<>1590842347
  Требует: icc-profiles
  Требует: mypaint-brushes1.0
  Требует: </lib64/ld-linux-x86-64.so.2>
    glibc-core-6:2.27-alt12:p9+243233.100.2.1<>1577350190
  Требует: </usr/bin/env>
    coreutils-8.31.0.3.6bd78-alt2:p9+233308.100.1.1<>1561631908
  Требует: <libIex-2_3.so.24()(64bit)>
    libiex24-2.3.0-alt1:p9+237895.300.1.1<>1568985254
  Требует: <libIlmImf-2_3.so.24()(64bit)>
    libilmimf24-2.3.0-alt1:p9+237895.400.1.1<>1568985455
  Требует: <libX11.so.6()(64bit)>
    libX11-3:1.6.7-alt1:sisyphus+226735.100.2.2<>1554615009
  Требует: <libXcursor.so.1()(64bit)>
    libXcursor-1.2.0-alt1:sisyphus+225206.400.1.2<>1552949214
  Требует: <libXext.so.6()(64bit)>
    libXext-1.3.4-alt1:sisyphus+225206.700.1.2<>1552949422
  Требует: <libXfixes.so.3()(64bit)>
    libXfixes-5.0.3-alt1:sisyphus+226736.100.2.2<>1554614842
  Требует: <libXmu.so.6()(64bit)>
    libXmu-1.1.3-alt1:sisyphus+225206.1200.1.2<>1552949629
  Требует: <libXpm.so.4()(64bit)>
    libXpm-3.5.12-alt1:sisyphus+223149.400.2.1<>1551268300
  Требует: <libasound.so.2()(64bit)>
    libalsa-1:1.1.9-alt2:sisyphus+229323.100.1.1<>1557826762
  Требует: <libasound.so.2(ALSA_0.9)(64bit)>
    libalsa-1:1.1.9-alt2:sisyphus+229323.100.1.1<>1557826762
  Требует: <libbabl-0.1.so.0()(64bit)>
    libbabl-0.1.74-alt1:p9+251602.20.8.1<>1590761419
  Требует: <libbz2.so.1()(64bit)>
    bzlib-1:1.0.6-alt6:sisyphus+224341.100.1.1<>1552254551
  Требует: <libc.so.6(GLIBC_2.3)(64bit)>
    glibc-core-6:2.27-alt12:p9+243233.100.2.1<>1577350190
  Требует: <libcairo.so.2()(64bit)>
    libcairo-1:1.16.0-alt1:sisyphus+226534.100.2.3<>1554515520
  Требует: <libdl.so.2(GLIBC_2.2.5)(64bit)>
    glibc-core-6:2.27-alt12:p9+243233.100.2.1<>1577350190
  Требует: <libfontconfig.so.1()(64bit)>
    fontconfig-2.13.1-alt1:p9+247340.200.3.1<>1583400482
  Требует: <libfreetype.so.6()(64bit)>
    libfreetype-2.10.1-alt1:p9+247340.100.1.1<>1583394162
  Требует: <libgcc_s.so.1(GCC_3.0)(64bit)>
    libgcc1-8.4.1-alt0.p9.1:p9+247559.100.2.1<>1585587756
  Требует: <libgdk-x11-2.0.so.0()(64bit)>
    libgtk+2-2.24.32-alt3:sisyphus+227306.100.1.3<>1555646039
  Требует: <libgdk_pixbuf-2.0.so.0()(64bit)>
    libgdk-pixbuf-2.38.2-alt1:p9+237353.1000.2.2<>1568374008
  Требует: <libgegl-0.4.so.0()(64bit)>
    libgegl-0.4.22-alt1:p9+251602.440.10.1<>1590841687
  Требует: <libgegl-npd-0.4.so()(64bit)>
    libgegl-0.4.22-alt1:p9+251602.440.10.1<>1590841687
  Требует: <libgexiv2.so.2()(64bit)>
    libgexiv2-0.12.0-alt1:p9+236761.300.2.1<>1567094342
  Требует: <libgio-2.0.so.0()(64bit)>
    libgio-2.60.7-alt1:p9+237353.100.2.2<>1568372980
  Требует: <libglib-2.0.so.0()(64bit)>
    glib2-2.60.7-alt1:p9+237353.100.2.2<>1568372980
  Требует: <libgobject-2.0.so.0()(64bit)>
    glib2-2.60.7-alt1:p9+237353.100.2.2<>1568372980
  Требует: <libgs.so.9()(64bit)>
    libgs-9.27-alt1:p9+230401.100.1.1<>1558957679
  Требует: <libgtk-x11-2.0.so.0()(64bit)>
    libgtk+2-2.24.32-alt3:sisyphus+227306.100.1.3<>1555646039
  Требует: <libgudev-1.0.so.0()(64bit)>
    libgudev-1:233-alt1:p9+235498.500.2.1<>1565021350
  Требует: <libharfbuzz.so.0()(64bit)>
    libharfbuzz-2.6.2-alt1:p9+238790.200.1.1<>1570435797
  Требует: <libheif.so.1()(64bit)>
    libheif-1.6.2-alt1:p9+244301.100.3.1<>1582815556
  Требует: <libjpeg.so.62()(64bit)>
    libjpeg-2:2.0.2-alt1:sisyphus+226996.100.1.1<>1554902884
  Требует: <libjson-glib-1.0.so.0()(64bit)>
    libjson-glib-1.4.4-alt1:sisyphus.213175.100<>1537249583
  Требует: <liblcms2.so.2()(64bit)>
    liblcms2-2.9-alt1<>1516411888
  Требует: <liblzma.so.5()(64bit)>
    liblzma-5.2.4-alt1:sisyphus+221902.5700.4.1<>1550600683
  Требует: <liblzma.so.5(XZ_5.0)(64bit)>
    liblzma-5.2.4-alt1:sisyphus+221902.5700.4.1<>1550600683
  Требует: <libm.so.6(GLIBC_2.27)(64bit)>
    glibc-core-6:2.27-alt12:p9+243233.100.2.1<>1577350190
  Требует: <libmng.so.2()(64bit)>
    libmng-2.0.3-alt2:sisyphus+222619.100.1.1<>1550943871
  Требует: <libmypaint.so.0()(64bit)>
    libmypaint-1.6.1-alt1:p9+251602.140.10.1<>1590841339
  Требует: <libopenjp2.so.7()(64bit)>
    libopenjpeg2.0-2.3.1-alt1:sisyphus+226454.100.1.1<>1554284336
  Требует: <libpango-1.0.so.0()(64bit)>
    libpango-1.44.6-alt1:p9+237353.700.2.2<>1568373865
  Требует: <libpangocairo-1.0.so.0()(64bit)>
    libpango-1.44.6-alt1:p9+237353.700.2.2<>1568373865
  Требует: <libpangoft2-1.0.so.0()(64bit)>
    libpango-1.44.6-alt1:p9+237353.700.2.2<>1568373865
  Требует: <libpng16.so.16()(64bit)>
    libpng16-1.6.36-alt1:sisyphus+219478.100.1.1<>1547633315
  Требует: <libpng16.so.16(PNG16_0)(64bit)>
    libpng16-1.6.36-alt1:sisyphus+219478.100.1.1<>1547633315
  Требует: <libpoppler-glib.so.8()(64bit)>
    libpoppler8-glib-0.80.0-alt1:p9+237607.100.1.1<>1568643072
  Требует: <librsvg-2.so.2()(64bit)>
    librsvg-1:2.46.4-alt1:p9+248366.400.6.1<>1587060872
  Требует: <libstdc++.so.6(CXXABI_1.3)(64bit)>
    libstdc++6-8.4.1-alt0.p9.1:p9+247559.100.2.1<>1585587756
  Требует: <libstdc++.so.6(CXXABI_1.3.9)(64bit)>
    libstdc++6-8.4.1-alt0.p9.1:p9+247559.100.2.1<>1585587756
  Требует: <libstdc++.so.6(GLIBCXX_3.4)(64bit)>
    libstdc++6-8.4.1-alt0.p9.1:p9+247559.100.2.1<>1585587756
  Требует: <libstdc++.so.6(GLIBCXX_3.4.21)(64bit)>
    libstdc++6-8.4.1-alt0.p9.1:p9+247559.100.2.1<>1585587756
  Требует: <libtiff.so.5()(64bit)>
    libtiff5-4.0.10.0.57.f9fc01c3-alt1:sisyphus+226958.100.1.1<>1554850937
  Требует: <libwebkitgtk-1.0.so.0()(64bit)>
    libwebkitgtk2-2.4.11-alt10:p9+247371.115200.170.1<>1592248094
  Требует: <libwebp.so.7()(64bit)>
    libwebp7-1.0.3-alt1:p9+234901.200.1.1<>1563552213
  Требует: <libwebpdemux.so.2()(64bit)>
    libwebp7-1.0.3-alt1:p9+234901.200.1.1<>1563552213
  Требует: <libwebpmux.so.3()(64bit)>
    libwebp7-1.0.3-alt1:p9+234901.200.1.1<>1563552213
  Требует: <libwmf-0.2.so.7()(64bit)>
    libwmf-0.2.8.4-alt13<>1506519334
  Требует: <libwmflite-0.2.so.7()(64bit)>
    libwmflite-0.2.8.4-alt13<>1506519334
  Требует: <libz.so.1()(64bit)>
    zlib-1.2.11-alt1:sisyphus+221902.6000.4.1<>1550600768
  Требует: python-base
  Требует: python-modules
  Требует: <python2.7(code)>
    python-modules-compiler-2.7.16-alt1.M90P.1:p9+244933.100.1.1<>1579867164
  Требует: <python2.7(gobject)>
    python-module-pygobject-2.28.7-alt1<>1513944003
  Требует: <python2.7(gtk)>
    python-module-pygtk-2.24.0-alt7:p9+237353.3000.2.2<>1568377029
  Требует: <python2.7(inspect)>
    python-modules-compiler-2.7.16-alt1.M90P.1:p9+244933.100.1.1<>1579867164
  Требует: <python2.7(keyword)>
    python-modules-compiler-2.7.16-alt1.M90P.1:p9+244933.100.1.1<>1579867164
  Требует: <python2.7(pango)>
    python-module-pygtk-2.24.0-alt7:p9+237353.3000.2.2<>1568377029
  Требует: <python2.7(pygtk)>
    python-module-pygobject-2.28.7-alt1<>1513944003
  Требует: <python2.7(xml)>
    python-modules-xml-2.7.16-alt1.M90P.1:p9+244933.100.1.1<>1579867164
  Требует: <rtld(GNU_UNIQUE)>
    glibc-core-6:2.27-alt12:p9+243233.100.2.1<>1577350190
  Требует: libgimp = 2.10.18-alt2:p9+251602.500.10.1
  Конфликтует: <gimp2-perl>
  Конфликтует: create-resources <= 0.1.3-alt1
  Вытесняет: <gimp2>

Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 29.7.2020, 22:40
Сообщение #23


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Да уж. В убедительности что делать этого не ст0ит Вы превзошли самого себя. Столь наглядно показано, сколь я ещё не встречал...
Хотя жаль...
Зато команду новую узнал, тоже хорошо.

Сообщение отредактировал robinzoid - 29.7.2020, 22:43


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 15.8.2020, 15:38
Сообщение #24


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Кстати о новых командах. А как можно удалить дроидкам со всеми потрохами? В Синаптике что было я удалил, теперь остался со стороны поставленный. Возможно вся моя колбасня именно со старого дроидкама и надо установить новый.
Возюкался сейчас в лайв-сили Кубунты, установленный дрюша снова завочевряжился типа занят другим клиентом. Подождал, загрузился снова - уже не занят... Похоже дрюша с того сайта динамичен и разрабатывается. Остаётся подождать пока его сделают.
А когда сделают, наверно надо установить его по-новой, для чего удалить старый. А я не знаю как это делается. В сети рецепты есть, но боязно удалить лишнее...


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 15.8.2020, 16:20
Сообщение #25


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Цитата(robinzoid @ 15.8.2020, 14:38) *
Кстати о новых командах. А как можно удалить дроидкам со всеми потрохами?

Ваобще-то есть команда
Код
rpm -q --filesbypkg <название пакета>

Она показывает все файлы, появившиеся при установке данного пакета. Но не знаю, как тут с Дроидкамом - он же вроде нестандартным образом установлен.

Цитата(robinzoid @ 15.8.2020, 14:38) *
Возюкался сейчас в лайв-сили Кубунты, установленный дрюша снова завочевряжился типа занят другим клиентом. Подождал, загрузился снова - уже не занят... Похоже дрюша с того сайта динамичен и разрабатывается.

А может, причина у тебя? Может, "другой клиент" появляется или исчезает при каких-то определённых условиях? Или этот вариант уже досконально исследован и отвергнут?


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 15.8.2020, 17:15
Сообщение #26


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Наверняка у меня но не только.
Просто мой дрюша на Кубунте сразу (полтора года назад) заявил что он занят другим клиентом. В Альте на тогда удалось его установить нормально я и успокоился.
Сейчас дрюша Альта не работает, пришлось вернуться на Кубунту 14.04. Но и там всё то же самое.
Вчера грузил лайв-сиди Кубунты 18.04, дрюша работал как часы, а сегодня его заколбасило. Грузюсь так же, в лайв-сиди настройки не меняются. Я думаю тот, сетевой архив ещё не закончен, ещё в разработке, видимо потому. Наверно справятся. А когда справятся мне хотелось бы вместо своего, занятого клиентом, поставить новый. Может в этом случае заработает.
Самое противное что на usb-камеру я уже раскошелился, но zoom её в упор не открывает. Видит, но не открывает.


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 15.8.2020, 23:48
Сообщение #27


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Ну тут столько частностей-тонкостей, что разве что сами пользователи Дроидкама, пожалуй, способны дать полезную информацию mellow.gif


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 16.8.2020, 9:13
Сообщение #28


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Да я и сам не думал что их будет столько. Наверно придётся методом тыка. Ставить, не то - сносить. Снова ставить и так пока не заработает.
А командой апт-гет и типа того его как-нить можно удалить?


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 16.8.2020, 23:32
Сообщение #29


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8071
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Едва ли от apt-get тут может быть польза. По-моему, чтобы в этой путанице разобраться, надо хотя бы составить типа таблицу: вот такая-то система, в ней такая-то версия дроидкама, работает так-то; а вот другая система... и так далее. Словом, систематизировать это дело, чтобы обстановка была изложена коротко и ясно.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 17.8.2020, 11:20
Сообщение #30


Профессионал
*******

Группа: Пользователь
Сообщений: 1979
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Ну и ладно. Команду мне подсказали. sudo /opt/droidcam-uninstall Вроде удалилось всё.
Я сейчас на Кубунте 14.04, на ней дрюша ещё подаёт признаки жизни. Ставил с архива закачанного в то время. Архив цепляю. Всё остальное уже 64-битное а я ещё на 32-х. Вроде всё путём, но этот дрюша как изначально оказался занят другим клиентом, так и продолжает им заниматься.

Прикрепленный файл  32.zip ( 1.26 мегабайт ) Кол-во скачиваний: 0


На лайв-сиди Альта 9 дрюша просто не встаёт, на Кубунте 18-04 (лайв-64) ругается. Сама ругань выглядит вот так.Прикрепленный файл  droidcam.txt ( 2.93 килобайт ) Кол-во скачиваний: 1
Прикрепленный файл  droidcam2.txt ( 668 байт ) Кол-во скачиваний: 2



Сообщение отредактировал robinzoid - 17.8.2020, 12:14


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
( Гостей: 1 )
Пользователей: 0

 



RSS Текстовая версия Сейчас: 26.9.2020, 21:51