IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> Расширение LinkR, Для создания внутренних линков из одного материала на другой материал
Поделиться
DIN
сообщение 18.5.2012, 8:56
Сообщение #1


Странник
**

Группа: Модератор раздела
Сообщений: 47
Регистрация: 12.4.2007
Вставить ник
Цитата
Пользователь №: 183
Страна: Россия
Город: Нижний Новгород
Пол: Муж.



Репутация: 0


Расширение LinkR
Сайт разработчика: http://j.l33p.com/linkr
Страница загрузки: http://joomlacode.org/gf/project/linkr2/frs/
Linkr is released under the GNU/GPL licence

Крайне нужная вещь для создания ссылок из текста одного материала на другой материал. Это очень странно, но в джумле до версии 1.5 включительно нет встроенного средства для этой цели. А надобность такая возникает почти всегда, даже на самом простом сайте.

Этот небольшой компонент выполняет, в принципе, те же функции, что и плагин AdvancedLink визуального редактора JCE.
После установки компонента, на странице редактирования материала, под редактором, внизу появится кнопка «Linkr». Вставка ссылки производится следующим образом:

Необходимо выделить часть текста материала
Нажать кнопку «Linkr» в нижней части страницы
В открывшемся окне выбрать необходимый материал (тут есть и другие вариации - куда ссылаться, например на пункт меню)
Нажать кнопку «Get Link»

Так же во всплывающем окне вы можете задать разные параметры для создаваемой ссылки. Ссылку можно сделать не только на другой материал, но и на загруженные медиа файлы, контакты или пункты меню.
На текущий момент последняя версия 2.3.9

Для установки на j1.5 нужно ставить два плагина, сам компонент и нужный языковый файл. Для j1.6 и j1.7 можно воспользоваться одним только суперинсталлером.
На сайте разработчика версия 2.3.9 декларирируется как для j1.7. Теоретически он должен подойти и на j2.5, но у меня с первого раза установка не получилась. А вторую я не предпринял. Потому как в j2.5 появилась встроенная возможность ставить внутренний линк на другой материал (наконец-то). Разработчик в связи с этим устраивает на своём сайте опрос народа на тему "надо ли продолжать поддержку компонента". Народ вроде говорит - ДА. Но разработчик видимо охладел.

Итого компонент нужно ставить по умолчанию, если у вас версия джумлы ниже 2.5 и при этом вы не ставите что-то вроде редактора JCE (в котором есть заменитель).
На j2.5 - это по желанию smile.gif
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
( Гостей: 1 )
Пользователей: 0

 



RSS Текстовая версия Сейчас: 26.2.2020, 13:52