IPB

Здравствуйте, гость ( Вход | Регистрация )

2 страниц V  < 1 2  
Ответить в эту темуОткрыть новую тему
> Gimp. Фильтр ''Альфа в логотип''
Поделиться
robinzoid
сообщение 21.3.2021, 15:56
Сообщение #31


Профессионал
*******

Группа: Пользователь
Сообщений: 2034
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Вот и мне подумалось что они чем-то могут пригодиться. Ну у них внутри есть исполняемые файлы,которые (как мне кажется) надо запустить.
Прикрепленный файл  500.jpeg ( 221.18 килобайт ) Кол-во скачиваний: 3

А так-то при мне из всего этого богатства только скрипт Глосси нужен. Я его использую при выделывании роликов. Так-то он не критичен, пока к меня Кубунта 14.04 с Гимпом 2.8, там это нормально работает, но та Кубунта уже не поддерживается, хотел поставить 20.04, но там Гимп 2.10, а в нём этих фильтров нет.
Копировал, да, другие альфа вроде работают, но нужную колбасит.

Прикрепленный файл  Screenshot_20210320_183118.jpg ( 180.78 килобайт ) Кол-во скачиваний: 5
Прикрепленный файл  Screenshot_20210320_183247.jpg ( 261.93 килобайт ) Кол-во скачиваний: 5


Пишет

Plug-in "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu/script-fu)
attempted to install procedure "temp-procedure-number-1" with invalid parameter name "gradient width".
И не работает.

Сообщение отредактировал robinzoid - 21.3.2021, 16:13


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 21.3.2021, 22:12
Сообщение #32


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8161
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


У меня в /usr/share/gimp/2.0 есть каталоги brushes, patterns, scripts - и там много чего есть. В ~/.config/gimp/2.10 те же каталоги. причём в скриптах что-то есть, в других двух каталогов пусто. Это у меня Альт-9, Gimp 2.10.18, пакет gimp-data-extras установлен, Глосси сейчас запускал, вроде работает.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 22.3.2021, 11:35
Сообщение #33


Профессионал
*******

Группа: Пользователь
Сообщений: 2034
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Приятно слышать.
Наверно буду пробовать Альтовскую дату-экстрас скачать и может быть сочинить из неё деб-пакет. Может альтовские сделали поумнее. Глосси, если скрипты скопирую, у меня на Кубунте видится, но попытка изменить градиент приводит к неприятному окошку.

А в папке конфигов те же скрипты что и в юзр-шаре? Они дублируются или разные? Кубунтовская дата-экстрас альфу в логотоп не загружает. Её просто нет.
Прикрепленный файл  1.jpg ( 240.18 килобайт ) Кол-во скачиваний: 1
Прикрепленный файл  2.jpg ( 170.66 килобайт ) Кол-во скачиваний: 0



--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 22.3.2021, 12:32
Сообщение #34


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8161
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


Я тогда невнимательно глянул - просто в Глосси залил картинку градиентом - всё нормально; но ты ведь про эту ошибку говорил:
Код
Plug-in "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu/script-fu)
attempted to install procedure "temp-procedure-number-1" with invalid parameter name "gradient width".

Да, она и в Альте выскакивает, если нажать в Глосси на какую-либо из кнопок "Обзор" sad.gif
Сам я Глосси не пользуюсь, так что не знаю, что там и как.

Цитата(robinzoid @ 22.3.2021, 10:35) *
А в папке конфигов те же скрипты что и в юзр-шаре?

Разные:
Код
[ivk<>host-136 ~]$ ls /usr/share/gimp/2.0/scripts/
add-bevel.scm              mkbrush.scm
addborder.scm              old-photo.scm
blend-anim.scm             palette-export.scm
burn-in-anim.scm           paste-as-brush.scm
carve-it.scm               paste-as-pattern.scm
chrome-it.scm              perspective-shadow.scm
circuit.scm                plug-in-compat.init
clothify.scm               predator.scm
coffee.scm                 reverse-layers.scm
copy-visible.scm           ripply-anim.scm
difference-clouds.scm      round-corners.scm
distress-selection.scm     script-fu-compat.init
drop-shadow.scm            script-fu.init
erase-rows.scm             script-fu-set-cmap.scm
font-map.scm               script-fu-util.scm
fuzzyborder.scm            selection-round.scm
gimp-online.scm            select-to-brush.scm
gradient-example.scm       select-to-image.scm
grid-system.scm            select-to-pattern.scm
guides-from-selection.scm  slide.scm
guides-new-percent.scm     spinning-globe.scm
guides-new.scm             spyrogimp.scm
guides-remove-all.scm      tileblur.scm
images                     unsharp-mask.scm
ISONoiseReduction.scm      waves-anim.scm
lava.scm                   weave.scm
line-nova.scm              xach-effect.scm

[ivk<>host-136 ~]$ ls ~/.config/gimp/2.10/scripts/        
3d-outline.scm               crystal-logo.scm
3dTruchet.scm                flatland.scm
alien-glow-arrow.scm         frosty-logo.scm
alien-glow-bar.scm           glossy.scm
alien-glow-bullet.scm        glowing-logo.scm
alien-glow-button.scm        gradient-bevel-logo.scm
alien-glow-logo.scm          i26-gunya2.scm
alien-neon-logo.scm          land.scm
basic1-logo.scm              Makefile.am
basic2-logo.scm              Makefile.in
beveled-button.scm           neon-logo.scm
beveled-pattern-arrow.scm    news-text.scm
beveled-pattern-bullet.scm   pupi-button.scm
beveled-pattern-button.scm   rendermap.scm
beveled-pattern-heading.scm  sota-chrome-logo.scm
beveled-pattern-hrule.scm    speed-text.scm
blended-logo.scm             starscape-logo.scm
bovinated-logo.scm           swirltile.scm
camo.scm                     swirly-pattern.scm
carved-logo.scm              text-circle.scm
chalk.scm                    textured-logo.scm
chip-away.scm                title-header.scm
chrome-logo.scm              t-o-p-logo.scm
comic-logo.scm               truchet.scm
coolmetal-logo.scm
[ivk<>host-136 ~]$


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 22.3.2021, 13:05
Сообщение #35


Профессионал
*******

Группа: Пользователь
Сообщений: 2034
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Значит разные. А то я мельком видел что и там и там куча скриптов, но Глосси только в корневой папке лежит.
Впрочем в новой Кубунте я его через mk туда и скопировал, а итог прежний...
Вроде нашёл тот злосчастный /usr/lib/gimp/2.0/plug-ins/script-fu/script-fu) но он в текстовом редакторе открылся в непонятной кодировке и с предупреждение вышло что он только для чтения.
Попытался было в новую Кубунту 20.04 поставить деб-пакет с Гимпом 2.8, там всё что нужно есть - так не встаёт...


kubuntu<>kubuntu:~$ ls
Desktop Видео Загрузки Музыка Шаблоны
gimp_2.8.22-1_amd64.deb Документы Изображения Общедоступные
kubuntu<>kubuntu:~$ sudo apt install ./gimp_2.8.22-1_amd64.deb
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Заметьте, вместо «./gimp_2.8.22-1_amd64.deb» выбирается «gimp»
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
gimp : Зависит: libgimp2.0 (>= 2.8.22) но он не будет установлен
Зависит: libgimp2.0 (<= 2.8.22-z) но он не будет установлен
Зависит: gimp-data (<= 2.8.22-z) но 2.10.18-1 должен быть установлен
Зависит: python-gtk2 (>= 2.8.0) но он не может быть установлен
Зависит: libgdk-pixbuf2.0-0 (>= 2.24.1) но он не будет установлен
Зависит: libdbus-glib-1-2 (>= 0.88) но он не будет установлен
Зависит: libgegl-0.3-0 (>= 0.3.0) но он не может быть установлен
Зависит: libglib2.0-0 (>= 2.41.1) но он не будет установлен
Зависит: libgtk2.0-0 (>= 2.24.10) но он не будет установлен
Зависит: libgudev-1.0-0 (>= 167) но он не будет установлен
Зависит: libpango-1.0-0 (>= 1.29.4) но он не будет установлен
Зависит: libpangocairo-1.0-0 (>= 1.29.4) но он не будет установлен
Зависит: libpangoft2-1.0-0 (>= 1.29.4) но он не будет установлен
Зависит: libpoppler-glib8 (>= 0.18.0) но он не будет установлен
Зависит: librsvg2-2 (>= 2.14.4) но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.




Сообщение отредактировал robinzoid - 24.3.2021, 18:43


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 4.4.2021, 15:30
Сообщение #36


Профессионал
*******

Группа: Пользователь
Сообщений: 2034
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Ура-банзай!
Поставил сейчас на флэшку Симпли slinux-live-9.0-x86_64, попробовал Гимп, поставил ему закачанные скрипты - есть глосси.

Прикрепленный файл  ______________2021_04_04_14_08_11.png ( 502.83 килобайт ) Кол-во скачиваний: 6


Стало быть новый Гимп 2.10 это умеет. Осталось подождать когда разрабы наших ОСей это решат и можно ставить новую ОСь.
Ну а пока - ждём-с..

Сообщение отредактировал robinzoid - 4.4.2021, 15:32


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
ИВК
сообщение 5.4.2021, 10:55
Сообщение #37


Профессионал
*******

Группа: Глоб. Модератор
Сообщений: 8161
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 27


На этом Симпли Гимп 2.10.13 - и есть Глосси, а в Альте последний 2.10.18 - и нет даже Альфа в логотип.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 5.4.2021, 15:41
Сообщение #38


Профессионал
*******

Группа: Пользователь
Сообщений: 2034
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 9


Нет-нет, альфы в лого и там изначально нет. Приходится скрипты вручную копировать. Просто Глосси не работающий на Кубунте заработал в Симпли. В нём Гимп 2.10 поновее с решённой заморочкой. Значит заработает и в более свежей Кубунте. Вот жду версию 21.04, проверить.


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

2 страниц V  < 1 2
Ответить в эту темуОткрыть новую тему
( Гостей: 1 )
Пользователей: 0

 



RSS Текстовая версия Сейчас: 14.4.2021, 5:09