IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> Установка программ в ALTLinux, ALT Linux, установка программ.
Поделиться
kostyalamer
сообщение 25.2.2010, 0:00
Сообщение #1


Профессионал
*******

Группа: Модератор раздела
Сообщений: 3734
Регистрация: 17.9.2009
Вставить ник
Цитата
Пользователь №: 1617
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 16


Установка программ в ALTLinux достаточно проста, но для того что бы изначально разобраться в этом вопросе
прочитайте статью: http://kostyalamer.narod.ru/ustanovka/ustanovka.html
Если все же что то не получается, то спрашивайте в этой теме коллектив форума Вам с удовольствием поможет smile.gif
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 25.2.2010, 14:01
Сообщение #2


Профессионал
*******

Группа: Пользователь
Сообщений: 1618
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 8


Константин, а скажем, если нет нужного пакета в репозитории. Например, для Гимпа хотел бы поставить расширение gimp-gap, как в Убунте, ан не выходит... Нету. Значит придётся искать на стороне.
и

В скобках: зато mathmap есть. У Убунты нету. Но с нею проще, скачал, запустил сразу установщиком...


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
IVK
сообщение 25.2.2010, 16:38
Сообщение #3


Профессионал
*******

Группа: Модератор раздела
Сообщений: 7266
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 26


А gimp-plugin-gap - не то же самое? У меня в Альт-4.1 он есть (версия 2.4.0); причём репозитории у меня подключены лишь обычные.
А если пакета в репозиториях Альта нет, то можно ведь просто скачать его откуда-нибудь и поставить командой rpm. Если, конечно, он не потащит за собой зависимости, которых в репозиториях тоже не окажется; но это в данном случае едва ли.

Сообщение отредактировал IVK - 25.2.2010, 16:39


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
kostyalamer
сообщение 25.2.2010, 22:05
Сообщение #4


Профессионал
*******

Группа: Модератор раздела
Сообщений: 3734
Регистрация: 17.9.2009
Вставить ник
Цитата
Пользователь №: 1617
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 16


Если нет альтовского пакета , то можно попробовать установить от Mandriva или Fedora. Устанавливать лучше :
apt-get install имя пакета ( включает полный путь: /home/Пользователь/папка/папка/имя_пакета ). Правда шансы установить чужой пакет не очень
велики .
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
robinzoid
сообщение 25.2.2010, 23:13
Сообщение #5


Профессионал
*******

Группа: Пользователь
Сообщений: 1618
Регистрация: 14.9.2009
Вставить ник
Цитата
Из: Ленинград
Пользователь №: 1594
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 8


Он самый, Иван... Вот в Убунте он через раз по-аглицки... В винде - весь по-русски. А в нашем, новом - вообще нет. М-да...
Ладно, побарахтаюсь так.


--------------------
El pueblo unido jamás será vencido! Если чего, я на http://robinzoid.ru/
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
DimonMMK
сообщение 27.2.2010, 2:11
Сообщение #6


Специалист
****

Группа: Пользователь
Сообщений: 153
Регистрация: 12.2.2010
Вставить ник
Цитата
Из: Подмосковье
Пользователь №: 1767
Страна: Россия
Город: Москва
Пол: Муж.



Репутация: 7


kostyalamer
Статья хорошая, но для лучшего понимания системы управления пакетами нужно прочесть ВОТ ЭТО, и особенно тщательно- 4-ю главу.
Очень подробно и как ни странно, понятно изложено.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
kostyalamer
сообщение 27.2.2010, 8:54
Сообщение #7


Профессионал
*******

Группа: Модератор раздела
Сообщений: 3734
Регистрация: 17.9.2009
Вставить ник
Цитата
Пользователь №: 1617
Страна: Россия
Город: Санкт-Петербург
Пол: Муж.



Репутация: 16


Цитата(DimonMMK @ 27.2.2010, 1:11) *
kostyalamer
Статья хорошая, но для лучшего понимания системы управления пакетами нужно прочесть ВОТ ЭТО, и особенно тщательно- 4-ю главу.
Очень подробно и как ни странно, понятно изложено.

Снова согласен с Вами, автору ( я то издатель, а не автор ), кстати сюда указывали, когда он опубликовывал статью в разделе документация форума Альта . Но поскольку статья хорошая и написана самостоятельно ( а не содрана с wiki ), то я ее опубликовал,так как считаю полезной.
PS про apt-get, есть гораздо более интересные материалы вроде вот этого:
http://www.debian.org/doc/manuals/apt-howto/ch1.ru.html smile.gif
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
time
сообщение 26.6.2016, 14:39
Сообщение #8


Крупный специалист
*****

Группа: Пользователь
Сообщений: 257
Регистрация: 14.7.2010
Вставить ник
Цитата
Пользователь №: 1870
Страна: Россия
Город: Брянск
Пол: Муж.



Репутация: 3


Время идёт! Мы незаметно стареем.
И наступает момент, когда понимаешь, что пенсию не зря дают.
Что тот привычный объём работ и интересов тебе уже не по силам, а удержаться в потоке событий, оставаясь нужным и молодому поколению и принося обществу пользу необходимо. Так приходишь к мысли о том, что для работы и общения с друзьями - ветеранами нужен какой-то простой, но удовлетворяющий основным интересам пожилых инструмент — операционная система с минимально необходимым набором программ.
Скачал в начале года два стартеркита — КДЕ-шный (в нём есть почти всё для удовлетворения любых потребностей нужно только выбросить лишнее) и ХФСЕ — быстрый, лёгкий и не требовательный к ресурсам (ветеранам, как правило, компьютеры достаются от детей и внуков), в который можно доустановить то, что тебе нужно. Оба 32-х битные.
Наступили каникулы и я начал с ХФСЕ, ковыряясь в утилитах репозитория и нанизывая на оболочку то, что либо уже выбрал, либо решил попробовать Невостребованные, такие как встроенный словарь, удалил .
Некоторые программы встают в оболочку «как влитые» (например словарь Стардикт), но некоторые, (например ДаблСоммандер) и в меню прописываются и работают, но когда я пытаюсь запустить из него файлы либре офиса, то мне открывается не документ а структура файла, а , когда я запрашиваю в консоли rpm -ql doblecommander, то следует ответ «пакет не установлен». Такая же история с запросом вывода пакетов Libre office, (из которого мне нужен только текстовый редактор).
Подскажите как интегрировать вновь устанавливаемые пакеты в оболочку (среду окружения)?
И какоё текстовый редактор можно попробовать, кроме Абиворда (он не работает с расширениями .odt and .doc.?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
IVK
сообщение 26.6.2016, 15:12
Сообщение #9


Профессионал
*******

Группа: Модератор раздела
Сообщений: 7266
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 26


По-моему, в подобных случаях лучше не связываться со стартеркитами (тем более если давно скачаны), а использовать готовое решение; проблем будет гораздо меньше. Если КДЕ у вас нормально работает, то можно поставить Комету (вариант home); её автор присутствует на нашем форуме, можно у него в случае чего спрашивать, да и я в ближайшее время буду заниматься этим дистрибутивом. А если KDE тяжеловат, то надо подыскивать что-то другое.


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Koi.v2
сообщение 6.12.2016, 19:51
Сообщение #10


Специалист
****

Группа: Пользователь
Сообщений: 229
Регистрация: 11.5.2015
Вставить ник
Цитата
Пользователь №: 2810
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Цитата(time @ 26.6.2016, 13:39) *
Наступили каникулы и я начал с ХФСЕ, ковыряясь в утилитах репозитория и нанизывая на оболочку то, что либо уже выбрал, либо решил попробовать Невостребованные, такие как встроенный словарь, удалил .
Некоторые программы встают в оболочку «как влитые» (например словарь Стардикт), но некоторые, (например ДаблСоммандер) и в меню прописываются и работают, но когда я пытаюсь запустить из него файлы либре офиса, то мне открывается не документ а структура файла, а , когда я запрашиваю в консоли rpm -ql doblecommander, то следует ответ «пакет не установлен». Такая же история с запросом вывода пакетов Libre office, (из которого мне нужен только текстовый редактор).
Подскажите как интегрировать вновь устанавливаемые пакеты в оболочку (среду окружения)?
И какоё текстовый редактор можно попробовать, кроме Абиворда (он не работает с расширениями .odt and .doc.?

Если Вы хотите поставить и работать, то лучше пользоваться официальными дистрибутивами в них на стадии установки можно выбрать комплект ПО. Или выключить его и потом до установить своё.

Наиболее простая и современная рабочая среда mate, но это моё личное мнение.
Пакет с double сommander называется doublecmd.

Есть список ПО он несколько недоделан, все руки не доходят. Можно глянуть в нем текстовые редакторы и офисные пакеты.
https://www.altlinux.org/SoftwareCenter/Applications
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
( Гостей: 1 )
Пользователей: 0

 



RSS Текстовая версия Сейчас: 22.10.2017, 0:59