IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в эту темуОткрыть новую тему
> Использование самых свежих версий программ в сборке на t7
Поделиться
tema
сообщение 19.2.2016, 12:37
Сообщение #1


Крупный специалист
*****

Группа: Пользователь
Сообщений: 496
Регистрация: 4.2.2016
Вставить ник
Цитата
Пользователь №: 2850
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Выделено из темы "Сторонние репозитории, репозитории p7"

Цитата(IVK @ 19.2.2016, 9:50) *
Описание идёт в комплекте с пакетом, оно не зависит от того, в каком репозитории тот лежит. Тут желательно уточнить, что именно требуется.

Ну для начала хочу сделать репозиторий и класть туда всегда самую свежую версию LibreOffice. Это критично, т.к. в репозитории p7 libreoffice неприлично протухшей версии. Последние версии libre, которые старше 4.4 хорошо открывают документы MS Office даже приемлемо многие презентации поверпоинта. Потом дополнительно кое-какие самописные программы для нашей школы (видимо, придётся освоить упаковку этих программ в rpm).
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
IVK
сообщение 19.2.2016, 19:28
Сообщение #2


Профессионал
*******

Группа: Модератор раздела
Сообщений: 7514
Регистрация: 22.6.2009
Вставить ник
Цитата
Из: Онега
Пользователь №: 1352
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 26


Если нужны самые свежие версии, то тогда лучше использовать не p7/t7, а Sisyphus, тем более что он, похоже, уже вполне стабилен и скоро превратится в p8/t8. Это, видимо, разумнее, чем смешивать пакеты из разных веток. Коллеги, что посоветуете? smile.gif


--------------------
Не пью, не курю, не смотрю телевизор, не пользуюсь Windows
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
Koi.v2
сообщение 19.2.2016, 19:46
Сообщение #3


Специалист
****

Группа: Пользователь
Сообщений: 229
Регистрация: 11.5.2015
Вставить ник
Цитата
Пользователь №: 2810
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Я хочу попробовать собрать дистрибутив на сизифе, а потом когда появится р8 просто убрать репы сизифа и воткнуть р8. Не знаю что получится, но в теории сизиф не должен вначале сильно отличатся от р8.
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
tema
сообщение 7.4.2016, 1:39
Сообщение #4


Крупный специалист
*****

Группа: Пользователь
Сообщений: 496
Регистрация: 4.2.2016
Вставить ник
Цитата
Пользователь №: 2850
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Вопрос снова стал актуален в связи с получившимся дистрибутивом.
Как я делаю сейчас: http://solvpro.ru/179
Хочу сделать через репозиторий. Допустим, я скачаю файлы LibreOffice и переименую их начала в LOkometa. Потом положу эти файлы в репозиторий в свой и установлю. Когда будут выходить новые версии LO мне надо будет просто обновить файлы в репозитории и всё? Есть ли какие-то подводные камни в именовании файлов?
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
tema
сообщение 7.4.2016, 2:49
Сообщение #5


Крупный специалист
*****

Группа: Пользователь
Сообщений: 496
Регистрация: 4.2.2016
Вставить ник
Цитата
Пользователь №: 2850
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Всё получилось http://school830.ru/myrepo/
Только одна проблема на данный момент. Автообновления с 5.0.* до 5.1.* не получается, т.к. в синаптике они отображаются как разные программы:
libreoffice 5.0 и libreoffice 5.1
Автообновления работают только в пределах версии после точки :-(
как это вылечить? Как сделать так чтобы в синаптике они были как, например, lokometa, а не libreoffice 5.0?

Сообщение отредактировал tema - 7.4.2016, 3:09
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения
tema
сообщение 7.4.2016, 3:04
Сообщение #6


Крупный специалист
*****

Группа: Пользователь
Сообщений: 496
Регистрация: 4.2.2016
Вставить ник
Цитата
Пользователь №: 2850
Страна: Россия
Город: Не указан
Пол: Муж.



Репутация: 2


Пока, как идея, упаковать скрипт http://solvpro.ru/179 в rpm и выкладывать в репу именно его с автозапуском.
Или сделать скрипт, который просто удаляет старую версию и инсталлирует новую и выкладывать в репу новый либре и этот скрипт, опять же упакованный в rpm.
Оба способа мне нравятся, но я прямо разбился о момент создания спека. Этот спек - я вообще ни слова не понял что там должно быть. Киньтесь в меня, пожалуйста, примером спека для скрипта с автозапуском после установки. Скрипт, допустим, такой (myhw.sh):
Код
#!/bin/sh
echo "Hello world!">/tmp/helloworld.txt


Сообщение отредактировал tema - 7.4.2016, 3:08
Вернуться в начало страницы
 
+Ответить с цитированием данного сообщения

Ответить в эту темуОткрыть новую тему
( Гостей: 1 )
Пользователей: 0

 



RSS Текстовая версия Сейчас: 21.10.2019, 9:11