Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Проблема с установкой программ
Россия-2 > Форумы поддержки работающих проектов > Линукс для всех > Работа в Linux - Система
интересующийся
Выделено из темы "Переход на восьмой Альт"

Цитата(robinzoid @ 23.4.2017, 9:31) *
Выделено из темы "Проблемы с седьмым Альтом"

Опять проблема с седьмым Альтом. Ну то есть я понимаю что все цивилизованные люди уже давно на Альте восьмом, но вот не нравится мне КДЕ 5 чисто визуально. Пока остаюсь на седьмом.
А вопрос такой: у меня уже давно с p7 никаких обновлений не приходит. Видимо на него уже рукой махнули и не поддерживают. А если я репозиторием p8 назначу, у меня ничего не поломается?? Смысл в этом есть хоть какой?
Сдуру-то ведь много чего поломать можно.

видимо и на восьмой махнули.я сейчас пользую стартеркит с xfce. хотел свои привычные программы поставить так синаптик не может обеспечиь всеми зависимостями. пишет например : " Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
так жаль, это мой любимый во все времена легенький редактор....и не только от него придется отказаться....
а вот репы п6 до сих пор на удивление хорошо работают и очень даже экзотический софт можно найти
IVK
Установил в сборке на p8 abiword - естественно, со всеми зависимостями, включая тот самый abiword-data-3.0.2-alt0.M80P.1. Никаких проблем. Правда, это в 64-битной сборке.
kostyalamer
У меня он работает на p8 32-бита без каких либо проблем. А стартер у вас на SysVinit или SystemD ?
Антон Мидюков
Цитата(интересующийся @ 2.7.2018, 1:22) *
видимо и на восьмой махнули.я сейчас пользую стартеркит с xfce. хотел свои привычные программы поставить так синаптик не может обеспечиь всеми зависимостями. пишет например : " Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
так жаль, это мой любимый во все времена легенький редактор....и не только от него придется отказаться....
а вот репы п6 до сих пор на удивление хорошо работают и очень даже экзотический софт можно найти


Обновляться нужно через dist-upgrade в консоли.
apt-get update && apt-get dist-upgrade
интересующийся
Цитата(IVK @ 1.7.2018, 21:05) *
Установил в сборке на p8 abiword - естественно, со всеми зависимостями, включая тот самый abiword-data-3.0.2-alt0.M80P.1. Никаких проблем. Правда, это в 64-битной сборке.

ну а у меня ничего не получается может потому что 32?
the following packages have unresorvable dependencies. make sure that all required repositories are added and enabled in the preferences
включены
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
что может быть не так?
speccyfighter
Цитата(интересующийся @ 1.7.2018, 20:22) *
видимо и на восьмой махнули. ... так синаптик не может обеспечиь всеми зависимостями. пишет например :
" Залежить: abiword-data (= 3.0.2-alt0.M80P.1), але його неможливо встановити"
что может быть не так?


Подозреваю что "його неможлыво встановыты" потому, что предварительно не обновлена локальная база пакетов:
- Базу менеджер отображает старую, с пакетами которых уже на сервере нет. Они уже обновились. Стало быть и локальную базу нужно обновить перед установкой пакета(ов).

В synaptic должны быть настроены цели для 32 бит:
Код
--------------------------------------------------------------------------------------------------------
|Разрешён|Тип|Поставщик|URI                                                 |Дистрибутив      |Раздел(ы) |
--------------------------------------------------------------------------------------------------------|
|   v     rpm p8        http://ftp.altlinux.org/pub/distributions/ALTLinux/  p8/branch/i586    classic   |
|   v     rpm p8        http://ftp.altlinux.org/pub/distributions/ALTLinux/  p8/branch/noarch  classic   |


Для установки abiword:

Нажать кнопку:
Оновити список пакунків
Ждать завершения операции.

Отметить двойным щелчком abiword

synaptic предложит окно:
Позначити необхідні додаткові зміни?
со списком пакетов включая abiword-data
Надо согласиться нажав кнопку
Позначити

Затем на панели synaptic нажать кнопку
Застосувати

В окне
Прийняти наступні зміні?
нажать кнопку
Застосувати

В окне
Завантаження файлів пакунків
начнётся процесс скачивания пакетов.

В конце появится окно
Прийняття змін
Ждите

По завершении всех операций появится окно
Вивід менеджера пакунків
с сообщением
Done (Готово)

Закройте окно нажав кнопку
Закрити
Все. smile.gif
speccyfighter
Цитата(интересующийся @ 3.7.2018, 9:38) *
ну а у меня ничего не получается может потому что 32?
the following packages have unresorvable dependencies. make sure that all required repositories are added and enabled in the preferences
включены
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
ftp://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
http://ftp.altlinux.org/pub/distributions/ALTLinux/
что может быть не так?


Проверил установку abiword через synaptic на установленной alt-p8-sysv-xfce-20180312-i586.iso
abiword устанавлиается и работает.

Уберите цели по протоколу ftp и оставьте только по http. Обновите локальную базу.
Что мне припоминается:
Редко, но пользуюсь местным сервером по ftp у которого вроде бы ограничение в полусотню коннектов. При превышении будет отказ в доступе.

Если есть apt-indicator, уберите его, - он чаще мешает чем помогает.
интересующийся
Цитата(Антон Мидюков @ 2.7.2018, 20:08) *
Обновляться нужно через dist-upgrade в консоли.
apt-get update && apt-get dist-upgrade

гениально! я знал! знал, но... забыл просто. давно не устанавливал систему.
ругается синаптик на фтп. я включил зеркала. пока работает. Эбиворд уже себе установил. радуюсь
интересующийся
alt-p8-xfce-20180612-i586 у меня что лежало на Альт линукс.орг-то и взял. лишь бына флеху гектарную влезло.
правда сначала МАТЕ или (МЭЙТ?) попробовал но отказаться пришлось хоть и понравился.
IVK
Переместил последнее сообщение отсюда в тему "Активатор windows". Тут у нас раздел про Линукс smile.gif Вообще, это не самый подходящий форум для решения виндовых проблем wink.gif
robinzoid
Так. Проблема с установкой программы.
На сайте http://www.dev47apps.com/droidcam/linuxx/ закачал дроид_кам_клиент для вроде бы своего компутера и теперь плохо представляю как его запустить на Альте...




Строго говоря я даже не представляю для моей ли архитектуры скачанное. Там висит зловещая надпись х86.
Состав скачанного я последовательно открыл в Конкуэроре, но вот чего с ним делать как-то теряюсь...
YYY
Цитата(robinzoid @ 5.2.2019, 15:53) *
Так. Проблема с установкой программы.


ну в терминале

uname -a

скажет какая архитектура
robinzoid
Говорит localdomain 4.9.151-std-def-alt0.M80P.1 #1 SMP Thu Jan 17 16:20:01 UTC 2019 i686 GNU/Linux
YYY
Цитата(robinzoid @ 5.2.2019, 21:45) *
Говорит localdomain 4.9.151-std-def-alt0.M80P.1 #1 SMP Thu Jan 17 16:20:01 UTC 2019 i686 GNU/Linux


ну тогда x86 верный выбор

теперь надо установить заголовки исходников ядра


apt-get install kernel-headers-std-def-4.9.151 kernel-headers-modules-std-def-4.9.151


robinzoid
[konst<>comp-pentium-dual-a80d8c ~]$ su -
Password:
[root<>comp-pentium-dual-a80d8c ~]# apt-get install kernel-headers-std-def-4.9.151 kernel-headers-modules-std-def-4.9.151
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Невозможно найти пакет kernel-headers-std-def-4.9.151
[root<>comp-pentium-dual-a80d8c ~]#

Есть только kernel-headers-std-def-4.9.154-alt0.M80P.1
YYY
Цитата(robinzoid @ 5.2.2019, 22:12) *



apt-get install kernel-image-std-def kernel-modules-v4l-std-def kernel-headers-std-def kernel-headers-modules-std-def
robinzoid
a80d8c ~]# apt-get install kernel-image-std-def kernel-modules-v4l-std-def kernel-headers-std-def kernel-headers-modules-std-def
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Виртуальный пакет kernel-image-std-def предоставляется следующими пакетами:
kernel-image-std-def#1:3.10.30-alt1 3.10.30-alt1 [Установлено]
kernel-image-std-def#1:4.9.58-alt0.M80P.1.1 4.9.58-alt0.M80P.1.1 [Установлено]
kernel-image-std-def#1:4.9.151-alt0.M80P.1 4.9.151-alt0.M80P.1 [Установлено]
kernel-image-std-def#1:4.9.147-alt0.M80P.1 4.9.147-alt0.M80P.1 [Установлено]
kernel-image-std-def#1:3.14.45-alt1 3.14.45-alt1 [Установлено]
kernel-image-std-def#1:3.14.79-alt0.M70P.2 3.14.79-alt0.M70P.2 [Установлено]
kernel-image-std-def#1:3.14.28-alt1 3.14.28-alt1 [Установлено]
kernel-image-std-def#1:3.14.36-alt1 3.14.36-alt1 [Установлено]
kernel-image-std-def#1:4.9.154-alt0.M80P.1 4.9.154-alt0.M80P.1
Необходимо точно указать, какой из пакетов должен быть установлен.
E: Виртуальный пакет kernel-image-std-def предоставляется многими пакетами.

[a80d8c ~]#


YYY
Цитата(robinzoid @ 5.2.2019, 22:31) *


apt-get install kernel-headers-std-def=4.9.151 kernel-headers-modules-std-def=4.9.151

а так ? smile.gif

или так

apt-get install kernel-headers-std-def=4.9.151-alt0.M80P.1 kernel-headers-modules-std-def=4.9.151-alt0.M80P.1

? smile.gif)
robinzoid
[konst<>comp-pentium-dual-a80d8c ~]$ su -
Password:
[root<>comp-pentium-dual-a80d8c ~]# apt-get install kernel-headers-std-def=4.9.151 kernel-headers-modules-std-def=4.9.151
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Версия ='4.9.151' для 'kernel-headers-std-def' не найдена
[root<>comp-pentium-dual-a80d8c ~]# apt-get install kernel-headers-std-def=4.9.151-alt0.M80P.1 kernel-headers-modules-std-def=4.9.151-alt0.M80P.1
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
E: Версия ='4.9.151-alt0.M80P.1' для 'kernel-headers-std-def' не найдена
[root<>comp-pentium-dual-a80d8c ~]#

Попробовал поставить в Синаптике ...std-def-4.9.154-alt0.M80P.1, нет... С маниакальной упёртостью говорит

[konst<>comp-pentium-dual-a80d8c ~]$ su -
Password:
[root<>comp-pentium-dual-a80d8c ~]# ls
2 AdbeRdr9.5.5-1_i486linux_enu.rpm Desktop tmp
[root<>comp-pentium-dual-a80d8c ~]# cd 2
[root<>comp-pentium-dual-a80d8c 2]# ls
droidcam droidcam-cli icon2.png install README uninstall v4l2loopback
[root<>comp-pentium-dual-a80d8c 2]# ./install
-- INSTALL: Webcam parameters: '640' and '480'
-- INSTALL: Home directory: /home/konst/.droidcam
-- INSTALL: Building v4l2loopback-dc.ko
make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/4.9.151-std-def-alt0.M80P.1/build: Нет такого файла или каталога. Останов.
make: *** [all] Ошибка 2
-- INSTALL: v4l2loopback-dc.ko not built.. Failure
[root<>comp-pentium-dual-a80d8c 2]#

YYY
Цитата(robinzoid @ 6.2.2019, 11:14) *


Ну тогда

apt-get install kernel-headers-std-def=4.9.154 kernel-headers-modules-std-def=4.9.154


или так

apt-get install kernel-headers-std-def=4.9.154-alt0.M80P.1 kernel-headers-modules-std-def=4.9.154-alt0.M80P.1


Все равно без этих пакетов нифига не собрать... Только ядро надо еще будет обновить до 4.9.154
robinzoid
Это я уже
[konst<>comp-pentium-dual-a80d8c ~]$ su -
Password:
[root<>comp-pentium-dual-a80d8c ~]# apt-get install kernel-headers-std-def=4.9.154 kernel-headers-modules-std-def=4.9.154
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Version kernel-headers-std-def#1:4.9.154-alt0.M80P.1 for kernel-headers-std-def=4.9.154 is already installed
Последняя версия kernel-headers-std-def уже установлена.
Version kernel-headers-modules-std-def#1:4.9.154-alt0.M80P.1 for kernel-headers-modules-std-def=4.9.154 is already installed
Последняя версия kernel-headers-modules-std-def уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
[root<>comp-pentium-dual-a80d8c ~]#

Но всё равно

[root<>comp-pentium-dual-a80d8c ~]# ls
2 AdbeRdr9.5.5-1_i486linux_enu.rpm Desktop tmp
[root<>comp-pentium-dual-a80d8c ~]# cd 2
[root<>comp-pentium-dual-a80d8c 2]# ./install
-- INSTALL: Webcam parameters: '640' and '480'
-- INSTALL: Home directory: /home/konst/.droidcam
-- INSTALL: Building v4l2loopback-dc.ko
make -C /lib/modules/`uname -r`/build M=`pwd`
make: *** /lib/modules/4.9.151-std-def-alt0.M80P.1/build: Нет такого файла или каталога. Останов.
make: *** [all] Ошибка 2
-- INSTALL: v4l2loopback-dc.ko not built.. Failure
[root<>comp-pentium-dual-a80d8c 2]#

То есть он хочет чисто 4.9.151 который мне взять неоткуда. А что такое "обновить ядро"??
YYY
Цитата(robinzoid @ 6.2.2019, 18:36) *
Это я уже



Походу
Дело вот в чем...
Ядро текущее 4.9.151
А заголовки 4.9.154


Что говорит ?


tree /lib/modules/ -L 2



Как я понимаю, теперь надо переехать на свежее ядро 4.9.154

https://www.altlinux.org/%D0%9E%D0%B1%D0%BD...%B4%D1%80%D0%B0

apt-get update
apt-get install update-kernel


и перегрузится

после перезагрузки на

uname -a

должно говорить что оно уже не 4.9.151 а 4.9.154

и тогда уже пробовать
robinzoid
Пока говорит

[konst<>comp-pentium-dual-a80d8c ~]$ tree /lib/modules/ -L 2
bash: tree: команда не найдена
[konst<>comp-pentium-dual-a80d8c ~]$

[konst<>comp-pentium-dual-a80d8c ~]$ su -
Password:
[root<>comp-pentium-dual-a80d8c ~]# apt-get update
Получено: 1 http://ftp.altlinux.org p8/branch/i586 release [880B]
Получено: 2 http://ftp.altlinux.org p8/branch/noarch release [673B]
Получено 1553B за 0s (10,9kB/s).
Найдено http://ftp.altlinux.org p8/branch/i586/classic pkglist
Найдено http://ftp.altlinux.org p8/branch/i586/classic release
Найдено http://ftp.altlinux.org p8/branch/noarch/classic pkglist
Найдено http://ftp.altlinux.org p8/branch/noarch/classic release
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
[root<>comp-pentium-dual-a80d8c ~]# apt-get install update-kernel
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия update-kernel уже установлена.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 0 не будет обновлено.
[root<>comp-pentium-dual-a80d8c ~]#


[root<>comp-pentium-dual-a80d8c ~]# uname -a
Linux comp-pentium-dual-a80d8c.localdomain 4.9.151-std-def-alt0.M80P.1 #1 SMP Thu Jan 17 16:20:01 UTC 2019 i686 GNU/Linux
[root<>comp-pentium-dual-a80d8c ~]#

Выполнил просто update-kernel
перезагрузился

[konst<>comp-pentium-dual-a80d8c ~]$ uname -a
Linux comp-pentium-dual-a80d8c.localdomain 4.9.154-std-def-alt0.M80P.1 #1 SMP Thu Jan 31 22:53:49 UTC 2019 i686 GNU/Linux
[konst<>comp-pentium-dual-a80d8c ~]$

[root<>comp-pentium-dual-a80d8c 2]# ./install
-- INSTALL: Webcam parameters: '640' and '480'
-- INSTALL: Home directory: /home/konst/.droidcam
-- INSTALL: Building v4l2loopback-dc.ko
make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Вход в каталог `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
LD /root/2/v4l2loopback/built-in.o
CC [M] /root/2/v4l2loopback/v4l2loopback-dc.o
/root/2/v4l2loopback/v4l2loopback-dc.c:2331:30: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
.vidioc_s_std = &vidioc_s_std,
^
/root/2/v4l2loopback/v4l2loopback-dc.c:2331:30: note: (near initialization for ‘v4l2_loopback_ioctl_ops.vidioc_s_std’)
/root/2/v4l2loopback/v4l2loopback-dc.c:2351:30: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
.vidioc_s_audio = &vidioc_s_audio,
^
/root/2/v4l2loopback/v4l2loopback-dc.c:2351:30: note: (near initialization for ‘v4l2_loopback_ioctl_ops.vidioc_s_audio’)
/root/2/v4l2loopback/v4l2loopback-dc.c:2353:30: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
.vidioc_s_audout = &vidioc_s_audout,
^
/root/2/v4l2loopback/v4l2loopback-dc.c:2353:30: note: (near initialization for ‘v4l2_loopback_ioctl_ops.vidioc_s_audout’)
cc1: some warnings being treated as errors
make[2]: *** [/root/2/v4l2loopback/v4l2loopback-dc.o] Ошибка 1
make[1]: *** [_module_/root/2/v4l2loopback] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
make: *** [all] Ошибка 2
-- INSTALL: v4l2loopback-dc.ko not built.. Failure
[root<>comp-pentium-dual-a80d8c 2]#

YYY
Цитата(robinzoid @ 6.2.2019, 21:37) *


так уже подвижки есть...


что говорит

gcc -v

?
YYY
Цитата(robinzoid @ 6.2.2019, 21:37) *


B что-то больно странный архив
на том сайте написано

wget https://www.dev47apps.com/files/600/droidcam-32bit.tar.bz2

Т.е. надо скачать этот файл и его собирать

https://www.dev47apps.com/files/600/droidcam-32bit.tar.bz2

он актуальный.
robinzoid
[konst<>comp-pentium-dual-a80d8c ~]$ gcc -v
Using built-in specs.
COLLECT_GCC=i586-alt-linux-gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i586-alt-linux/5/lto-wrapper
Target: i586-alt-linux
Configured with: ../configure --host=i586-alt-linux --build=i586-alt-linux --target=i586-alt-linux --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var/lib --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --disable-dependency-tracking --without-included-gettext --enable-shared --program-suffix=-5 --with-slibdir=/lib --with-bugurl=http://bugzilla.altlinux.org --enable-__cxa_atexit --enable-threads=posix --enable-checking=release --with-system-zlib --without-included-gettext --enable-multilib --enable-gnu-unique-object --enable-linker-build-id --with-linker-hash-style=gnu --with-arch=i586 --with-tune=generic --enable-bootstrap --enable-languages=c,c++,fortran,objc,obj-c++,java,ada,go,lto --enable-plugin --enable-java-awt=gtk --with-native-libdir=/usr/lib/gcj-5 --with-ecj-jar=/usr/share/java/ecj.jar --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-5-1.5.0.0/jre --enable-libgcj-multifile --disable-libjava-multilib --enable-java-maintainer-mode
Thread model: posix
gcc version 5.3.1 20151207 (ALT Linux 5.3.1-alt3) (GCC)
[konst<>comp-pentium-dual-a80d8c ~]$

И почему я чувствую себя как перед новыми воротами?
И не увидел откуда берётся новый архив. Тот что у меня скачалось это tar.gz а оказывается надо tar.bz2...

Насколько понимаю - установил...[root<>comp-pentium-dual-a80d8c ~]# ls
1 2 AdbeRdr9.5.5-1_i486linux_enu.rpm Desktop tmp
[root<>comp-pentium-dual-a80d8c ~]# cd 1
[root<>comp-pentium-dual-a80d8c 1]# ls
droidcam droidcam-cli install README uninstall v4l2loopback
[root<>comp-pentium-dual-a80d8c 1]# ./install
Webcam parameters: '640' and '480'
Building v4l2loopback-dc.ko
make: Вход в каталог `/root/1/v4l2loopback'
make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Вход в каталог `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
LD /root/1/v4l2loopback/built-in.o
CC [M] /root/1/v4l2loopback/v4l2loopback-dc.o
Building modules, stage 2.
MODPOST 1 modules
CC /root/1/v4l2loopback/v4l2loopback-dc.mod.o
LD [M] /root/1/v4l2loopback/v4l2loopback-dc.ko
make[1]: Выход из каталога `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
make: Выход из каталога `/root/1/v4l2loopback'
Moving driver and executable to system folders
Registering webcam device
Running depmod
make: Вход в каталог `/root/1/v4l2loopback'
make -C /lib/modules/`uname -r`/build M=`pwd` clean
make[1]: Вход в каталог `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
CLEAN /root/1/v4l2loopback/.tmp_versions
CLEAN /root/1/v4l2loopback/Module.symvers
make[1]: Выход из каталога `/usr/src/linux-4.9.154-std-def-alt0.M80P.1'
make: Выход из каталога `/root/1/v4l2loopback'
Adding uninstall script
Adding driver to /etc/modules
Done
[root<>comp-pentium-dual-a80d8c 1]#

Теперь непонятно где его в менюшке брать??? Кого искать? И в какой рубрике?

robinzoid
Что-ж. Итог.Спасибо за правильный архив. Я действительно скачал не тот (теперь бы хорошо узнать где он там на сайте висит). ДроидКам заработал, правда в менюшке его нет, но если настучать "дроидкам" в терминале, он и появится и подключится. Видеобудка Cheese с ним заработала, только телефон придётся укладывать на бок. В вертикально стоящем картинка лежит на боку.
Но главное - вэб-камера у меня теперь есть. Заодно есть побочная разборка с ядром и его модулями. Есть чего уложить в память.В общем, всё состоялось. Спасибо.



speccyfighter
Цитата(robinzoid @ 7.2.2019, 6:26) *
ДроидКам заработал, правда в менюшке его нет,


Потому что внутри архива кроме двух бинарников ничего нет. Там даже файла-иконки нет.
Меню приложений надо редактировать.
А ложатся бинарники install -ом сюда:
Код
...
cp droidcam /usr/bin/
cp droidcam-cli /usr/bin/
...

robinzoid
Вот это для меня тёмный лес.
YYY
Цитата(robinzoid @ 7.2.2019, 19:58) *
Вот это для меня тёмный лес.


Что-то на форуме отвалилась возможность добавить к сообщению файлы

http://file.sampo.ru/q55vkg/

вот два файла

droidcamx.png
надо поместить в каталог /usr/share/icons/

droidcamx.desktop
надо поместить в каталог /usr/share/applications/

smile.gif
IVK
Цитата(YYY @ 7.2.2019, 23:11) *
Что-то на форуме отвалилась возможность добавить к сообщению файлы

И в самом деле. Сообщу админу.
robinzoid
Спасибо. Теперь и в менюшке есть.



robinzoid
Кстати добавлю. На Альте, чтобы телефон стал вэб-камерой по проводу, а не по вай-фаю, надо в Синаптике в поиске ввести adb и когда поиск сработает, поставить пакет андроид_тулс. Сразу подключиться не получится, нужно ещё в самом телефоне немножко поколупаться, с отладкой по USB. Но это несложно.
И тогда телефон станет проводной вэб-камерой, в заодно и заряжаться юудет.





YYY
Цитата(robinzoid @ 10.2.2019, 16:30) *


хорошо что хорошо работает smile.gif
robinzoid
Ну да. В этом плане Вы накидали всё что нужно чтобы програшка заработала. Может поисковик и эту тему распознает, тогда читателей и почитателей будет больше.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Русская версия IP.Board © 2001-2019 IPS, Inc.